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VisSim/Real-TimePRO extends VisSim for use in interactive, real-time data
acquisition and control. VisSim/Real-TimePRO’s highly intuitive block diagram
interface makes it easy to acquire and display data, and conduct real-time analysis.
With VisSim’s MMI blocks, you can build realistic instrumentation panels to
observe and control system performance. Audio and visual alarms warn you when
system behavior crosses a boundary, hits a limit, or meets any other arbitrary
condition.

This manual describes how to use VisSim/Real-TimePRO and VisSim DACQ. If
you’ve purchased VisSim DACQ, be sure to read  “For VisSim DACQ users,” on
page viii, for a list of specifics about your version of the software.

��!��
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Before you begin using VisSim/Real-TimePRO or VisSim DACQ, please fill out the
enclosed registration card and mail it to us. As a registered user, you will receive a
free subscription to The flexWire, along with discount promotions and VisSim
workshop schedules.

�	�%��
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This manual assumes that you are already familiar with the VisSim graphical user
interface. If you need to review the interface, consult your VisSim User’s Guide or
the online help.
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The following typographical conventions are used in this manual:

Typographical convention Where it’s used

Shortcut key combinations Shortcut key combinations are joined with a plus sign (+).
For example, the command CTRL+C means to hold down the
CTRL key while you press the C key.

Hot keys Hot keys are the underlined keys in VisSim’s menus,
commands, and dialog boxes. To use a hot key, press ALT
and then the key for the underlined character. For instance, to
execute the File menu’s Real Time Config command, hold
down the ALT key while you press the F key, then release
both keys and press the R key.

SMALL CAPS To indicate the names of keys on the keyboard.

ALL CAPS To indicate directory names, file names, and acronyms.

Initial Caps To indicate menu names and command names.

In addition, unless specifically stated otherwise, when you read “click the mouse...”
or “click on...,” it means to click the left mouse button.

.	���������62�9������
If you have purchased VisSim DACQ, you will receive VisSim/Real-TimePRO
along with a compact version of VisSim that imposes a 100-block limit on each
block diagram you create.
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To help you get the most out of VisSim, the following online information is
available:

• Online help. The online help contains step-by-step instructions for using
VisSim features.

• Online release notes. A file named READMERT.TXT is installed in your main
VisSim directory. This file contains last minute information and changes that
were discovered after this manual went to print. For your convenience, you
should read this file immediately and print a copy of it to keep with this manual.
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VisSim’s Help program provides online instructions for using VisSim.

� To open Help

• Do one of the following:

To Do this

Access the top level of help Select Help from the menu bar or press
ALT+H.

Access help on the selected block Click on the Help command button in the
dialog box for the block.

� To close Help

• In the Help window, choose File > Exit, or press ALT+F4.

���"����������	�

When you need assistance with a Visual Solutions product, first look in the manual,
read the README.WRI file, and consult the online Help program. If you cannot
find the answer, contact the Technical Support group via toll call between 9:00 am
and 6:00 pm Eastern Standard Time, Monday through Friday, excluding holidays.
The phone number is 978-392-0100.

When you call in, please have the following information at hand:

• The version of VisSim and VisSim/Real-TimePRO (or VisSim DACQ), and the
version of the software operating environment that you are using

• All screen messages

• What you were doing when the problem happened

• How you tried to solve the problem

Visual Solutions also has the following fax and email addresses:

Address/Number What it’s for

978-692-3102 Fax number

bugs@vissol.com Bug report

doc@vissol.com Documentation errors and suggestions

sales@vissol.com Sales, pricing, and general information

tech@vissol.com Technical support
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Simulating in real-time mode has the effect of retarding a simulation so that one
simulation second equals one second in real time. Typically, you use real-time mode
for data acquisition or hardware-in-the-loop control situations. For this, however,
you need a VisSim/Real-TimePRO or VisSim DACQ.

�����
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The real-time drivers supplied with VisSim/Real-TimePRO and VisSim DACQ are
32-bit drivers that include:

• A protected-mode VxD that is automatically installed

• A VisSim Dynamic Link Library (DLL) file that provides a Windows protected
mode interface to the VxD

All real-time drivers support up to sixteen boards simultaneously. You can mix
different boards and drivers or use multiple instances of the same board. You set the
base I/O port address for the board through the File menu’s Real Time Config
command, as described in Chapter 2, “Configuring I/O Boards.”

����	�
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The following table lists the I/O boards supported by VisSim/Real-TimePRO and
VisSim DACQ. Because Visual Solutions is continually expanding the boards it
supports, please call Technical Support for the latest list of supported boards. Phone
and fax numbers can be found on page ix.
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Vendor Board name

Advantech PCL-711
PCL-711S
PCL-718
PCL-812
PCL-812PG
PCL-818
PCL-818PG

Interface PCLD-789

Analog Devices RTI 815

ComputerBoards
Analog Input CIO-DAS08

CIO-DAS08/AO
CIO-DAS08/AOH
CIO-DAS08/AOL
CIO-DAS08/Jr
CIO-DAS08-PGA
CIO-DAS08-PGH
CIO-DAS08-PGL
CIO-DAS16
CIO-DAS16/Jr
CIO-DAS16/330
CIO-DAS16/330-I
CIO-DAS481

CIO-DAS48PGA
CIO-DAS1601/12
CIO-DAS1602/12
CIO-DAS1602/16

Analog Output CIO-DAC02
CIO-DAC08
CIO-DAC08-I
CIO-DAC16
CIO-DAC16-I
CIO-DDA06
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Vendor Board name
ComputerBoards (continued)

Digital Input and Output CIO-DIO242

CIO-DIO24DD
CIO-DIO24H
CIO-DIO483

CIO-DIO48DD
CIO-DIO48H3

CIO-DIO964

CIO-DIO1925

CIO-PDIS08
Interface Boards to Digital I/O CIO-DUAL-AC5

CIO-ERB08
CIO-ERB24
CIO-ERB48
SSR-RACK08
SSR-RACK24
SSR-RACK48

PCMCIA (laptop) PCM-DAC026

PCM-DAC086

PCM-DAS166

PCM-DAS16/126

PCM-DAS16S/126

PCM-DAS16/166

Counter Timer CIO-CTR05
CIO-CTR05/H50
CIO-CTR107

CIO-CTR10/H508

Data Translations DTI-2811PGH
DTI-2811PGL

Keithley MetraByte
Analog Input DAS-08

DAS-08/AO
DAS-08/LT
DAS-08/PGA
DAS-16
DAS-1400
DAS-1600

Analog Output DAC-02
DAC-16
DDA-06
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Vendor Board name
Keithley MetraByte (continued)

Digital Input & Output PDISO8
PIO-24

National Instruments4 Lab-PC+
PC-AO-2DC
PC-DIO-24
PC-DIO-969

PCMCIA (laptop) DAQCard-1200
DAQCard-AO-2DC
DAQCard-DIO-24

Precision Micro Dynamics MFIO-3A (3 axis quadrature encoder with 3 16-bit
analog outputs)

1. Equivalent to three CIO-DAS16 on a single board.
2. Also supported in 24 input and 24 output modes.
3. Equivalent to two CIO-DIO24 on a single board.
4. Equivalent to four CIO-DIO24 on a single board.
5. Equivalent to eight CIO-DIO24 on a single board.
6. Supported by VisSim/Real-TimePRO under Windows 95 only.
7. Equivalent to two CIO-CTR05 on a single board.
8. Equivalent to two CIO-CTR05/H50 on a single board.
9. Equivalent to four PC-DIO-24 on a single board.

�"������������8�	�#�
VisSim/Real-TimePRO and VisSim DACQ offer five blocks:

Block What it’s for
��������� Configuring input channels

��������	� Configuring output channels


�� Producing pulse width modulated output


���	���� Measuring frequency input

������� Reading encoder input

These blocks are located under the Real Time category in the Blocks menu. After
VisSim/Real-TimePRO or VisSim DACQ has been successfully installed, the ���
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������ and ��������	� blocks are available for use. The 
��, 
���	����, and
������� blocks are available only if you have installed the following boards:

To use this block One of the following boards must be installed

�� Analog Devices: RTI 815; ComputerBoards: CIO-CTR05,

CIO-CTR05/H50, CIO-CTR10, CIO-CTR10/H50


���	���� Analog Devices: RTI 815; ComputerBoards: CIO-CTR05,
CIO-CTR05/H50, CIO-CTR10, CIO-CTR10/H50

������� Precision Micro Dynamics: MFIO-3A

6�
����/����
�	��!���������
Since Windows is not a multitasking operating system you must be careful about
what you do while acquiring data to avoid missing a sampling interval. Because
VisSim calculates all blocks before it begins each sampling interval, any one block
that runs slowly can disturb the acquisition process. Additionally, since there is only
one processor to calculate and draw the Windows graphics, you should avoid any
operation that causes Windows to repaint the screen. These operations include:

• Running DOS shells

• Digital display read-outs, strip charts, histograms, meters, and plots for greater
than 200 Hz sampling rates (shown in order, from most costly to least costly)

• Calling up a block’s Properties dialog box

• Expanding a plot to full screen

• Changing diagram layers

���$	���������!����
�	�
The performance degradation due to graphics use depends heavily on the speed of
the base processor and the graphics card. You should experiment with different
sampling rates and graphics usage to determine the limits of your system.
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This chapter covers the following information:

• Installing and configuring I/O boards

• Verifying I/O board settings

• Configuring VisSim/Real-TimePRO and VisSim DACQ to recognize your I/O
boards


��
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Typically, the installation and configuration of your I/O boards involves setting base
addresses, adjusting jumpers, and setting analog and digital ranges. Because this
information is unique to each board, it is important that you refer to the vendor’s
documentation for installing, configuring, and testing the board.

Keeping a record of your I/O board base address

You will need your I/O board’s base address later on when you
configure VisSim/Real-TimePRO or VisSim DACQ to recognize the
board. Therefore, it is recommended that you write down your boards’
base addresses and keep them in a safe place.
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If you need to determine the base address of one of your installed I/O boards, refer
to the vendor’s documentation. In many cases, the vendor distributes software that
allows you to check installed board settings.

Also, you may be able to use the Control Panel to determine base addresses for
installed boards. For instance, on the Windows 95 platform, you can find many
boards’ settings by using the Device Manager under Settings > Control Panel >
Device Manager. Refer to your Windows documentation for information on finding
I/O board settings.

�	�$�!����!���������������������	���������62�9�
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Any time you install or reconfigure an I/O board, you must also configure or
reconfigure VisSim/Real-TimePRO or VisSim DACQ to recognize the board. You
use the File > Real-Time Config command to perform these tasks.

����!�
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After installing your I/O board, follow these steps to configure VisSim/Real-
TimePRO or VisSim DACQ to recognize it:

1. Start VisSim or VisSim DACQ.

2. Choose File > Real Time Config.

 A setup dialog box appears.
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3. Select the hardware and software settings for the I/O board that will work with
the process or controller whose data you are acquiring or measuring. (See the
descriptions below for more information about each parameter.)

4. Click on the OK button, or press ENTER.

��
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The Board Number box lets you identify your I/O board with a unique number in the
range of 0 through 15. For instance, to differentiate two installed I/O boards, you can
assign one board number 0 and the other board number 1. The number you enter
here is used to identify your board later on when setting its input and output
channels.

The Board Type box identifies the model of your I/O board. When you click in the
box or on the DOWN ARROW, a list of available board types are displayed from which
you can choose.

��
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The Analog Input Range box lists the available analog input ranges for the selected
board type, while the Analog Output Range box lists the available analog output
ranges for the selected board type. Click on the DOWN ARROW to reveal a list of
additional ranges.

��
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The base address indicates the I/O port register address through which the real-time
driver commands the board. The base address was set at the time the board was
installed and configured. Enter the base address as a hexadecimal number in the
following format:

0xhexNumber

Base addresses are configurable between  0x110 and 0x3FF.

If you do not know the base address of your board, see page 8.

��
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The channel settling time is the time taken for the voltage to settle between channels
for multichannel reads. The settling time is entered in microseconds (µsec). The first
time you configure a board, it is recommended to use the default setting; you can
always change the setting later if it is too fast or too slow.

Most boards have a default settling time of 30 µsec.
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The external mux settling time is the time taken for the voltages to settle when using
the I/O boards with multiplexed subchannels. The default is 4 milliseconds (msec).
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This chapter covers the following information:

• Setting input channels using ��������� blocks

• Setting output channels using ��������	� blocks


���
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The ��������� and ��������	� blocks let you set the input and output channels
for your I/O boards. Each block sets a single channel. Thus, if you are using a 4
input, 4 output I/O board, you will need four ��������� blocks and four ���

�����	� blocks.

For each channel, you can specify a channel title, channel class, and channel type. In
addition, if you are setting the input channel on an I/O board with multiplexed
subchannels, you can also set the multiplex subchannel, mux gain, and cold junction
compensation for thermocouple linearization.
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To set an input channel on your I/O board, you use the ��������� block.

� To set up an input channel

1. Choose Blocks > Real Time and drag an ��������� block into the work area.

2. Do one of the following:

• Choose Edit > Block Properties and click the mouse over the ���������
block.

• Click the right mouse button over the ��������� block.

The Real Time Data Input dialog box appears.

3. Make the appropriate selections. (See the descriptions below for more
information about each parameter.)

4. Click on the OK button, or press ENTER.

�����$ ��!�
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In the Board Number box, enter the board number of the I/O board whose input
channel is to be configured. The board number was established with the File > Real
Time Config command, as described on page 9. If you are not sure of the board
number, click on the DOWN ARROW to reveal the list of configured board numbers.
When you select a board number, the board type is displayed beneath the board
number.
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When you configure a multi-channel I/O board, you can identify each channel with a
unique title. These titles appear on the ��������� blocks making it easier to
recognize which block is assigned to each channel.

�����$ ��!����"���������8��
In the Channel box, you enter a number that corresponds with the channel number
on the screw terminal or termination panel supplied with your I/O board. The ���
������ block uses channel 0 as the first channel, even if the documentation
supplied by the board vendor describes the first channel as channel 1.

8255-based digital I/O boards: If you are using an 8255-based digital I/O board,
you can connect ��������� channels to electrical connector terminals in several
different ways. Boards with an 8255 chip are listed below:

Vendor Board
ComputerBoards CIO-DIO24

CIO-DIO24H

Keithley MetraByte PIO-12

PIO-24

National Instruments PC-DIO-24

PC-DIO-96

DAQCard-1200

See Appendix A, “Connecting to Boards with an 8255 Chip” for more information.

PCM-CIA DAS 16/12 and DAS 16/16 boards: If you are connecting to a
ComputerBoards PCM-CIA DAS 16/12 or DAS 16/16, you can connect the ���
������ channels to electrical terminals in a specific way. See Appendix B,
“Connecting to PCM-CIA DAS 16/12 and DAS 16/16 Boards,” for more
information.

�����$ ��!���8�"������
When you are using an I/O board with multiplexed input channels, such as the CIO-
DAS08 board from ComputerBoards, you use the Multiplex Subchannel parameter
to connect the individual multiplex channels. Each multiplex board physically
connects to all of the analog input channels on the I/O board, letting you daisy chain
them. Electrically, each multiplex board only connects to one of the I/O board’s
input channels. The electrical connection connects to only one of the analog input
channels and depends on the jumper setting on the multiplex board. To set the
jumper, refer to the documentation that accompanies the board.
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When you activate the Multiplex Subchannel parameter, you must also enter a
subchannel number in the accompanying Multiplex Subchannel text box.
VisSim/Real-TimePRO or VisSim DACQ sends the multiplex subchannel number to
the first four digital output channels, which the multiplex board uses as the multiplex
subchannel  specifier, and then reads the input channel. (You should not use the
digital channels for other purposes.)

�����$ ��!�����3�!����$	�������
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The Mux Gain parameter indicates the gain applied to a multiplexed signal when it is
read into VisSim/Real-TimePRO or VisSim DACQ. In order to render an accurate
reading, VisSim/Real-TimePRO or VisSim DACQ uses this parameter to
compensate for the gain applied to the signal by the multiplexor board.

The Mux Gain parameter value must match the gain setting specified on the
multiplexor board to achieve accurate results.

When you change the mux gain on a channel, all the gains on all the multiplexed
subchannels are changed.

�����$ ��!����"�����������
The ��������� block recognizes six classes of inputs on I/O boards:

• Counter

• Current

• Digital

• Thermocouple

• Voltage

When you select a channel class, the options listed under the Channel Type box
change accordingly. For example, when you select Volts, the voltage ranges are
displayed.

In addition, before you select a channel class, make sure the hardware line has been
connected to the specified channel number.

�	��
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The Counter parameter utilizes your I/O board’s counter timer. A counter provides a
high frequency pulse counting input. Pulses are generated by triggering on the
leading edge of an incoming sinusoidally-shaped waveform. Most counters can
count approximately 64,000 pulses before they overflow and reset. In VisSim/Real-
TimePRO and VisSim DACQ, the counter value is reset at the end of every time step
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of the simulation. If you accumulate more than 64,000 counts, you should reduce the
step size using the Simulate > Simulation Properties command.

Most boards have at least one counter input. When using the counter channel, be
particularly careful connecting the screw terminal to the signal source. Most board
vendors re-use an existing digital channel for the counter input.

As an example of how Counter may be used, consider a sensor that generates a
sinusoid with a frequency that corresponds to the velocity of a fluid. Typical
frequencies can range from 1 to 10 kHz. Assuming that you have set the simulation
step size to 0.1 sec, the number of pulses that occur in one step of the simulation can
be computed by dividing the counter value (output of the ��������� block
configured to the counter) by the simulation time step.

������
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The Current parameter supports current output applications. It is set to a range of
4 - 20 mA, which provides a full 12 bits of resolution over the range.

This channel class appears only if your I/O board has current.

6�!�
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The Digital parameter provides an ON/OFF channel input. When Digital is
activated, the input behaves like a current sink. When the voltage level on the digital
input line goes low, current flows from the 5 V power supply to ground. When the
digital input channel is activated, the voltage level of the channel goes low (turns
off). Most digital input channels are capable of sinking 10 mA.

For digital inputs, the ��������� block uses the vendor’s  specifications for TTL-
level values.

�"���	�	������"�����������
The Thermocouple parameter provides thermocouple linearization input. A
thermocouple produces a voltage corresponding to the temperature measured.

When Thermocouple is activated, the Channel Type box shows different types of
thermocouples (B, E, J, K, R, S, and T).

VisSim/Real-TimePRO and VisSim DACQ provide for cold junction compensation
for the thermocouple linearization; it uses channel 7 on the I/O board for reading the
temperature from the solid state temperature device on the multiplexer board for cold
junction compensation.

�	�
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The Volts parameter provides a time varying voltage input. The range of the voltage
input is software-selectable for many boards. Boards with this characteristic are
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referred to as programmable gain boards. If you are using a programmable gain
board and you activate Volts, the voltage ranges are presented under the Channel
Type box. These typically range from ±10 to ±. .0 01 V and lower.

For boards without programmable gain, the input voltage range is normally set using
a micro-switch on the I/O board itself. The corresponding voltage ranges, listed
under the Channel Type box, are read-only settings.

The voltage channel is often called an A/D channel. Analog input signals are
converted to digital representations using a converter. The converter consists of
registers whose numbers determine the resolution. Most boards use 12-bit resolution
converters; however, some boards use higher resolution converters for greater
precision.

Channel resolution is proportional to channel read time. The higher the channel
resolution, the longer it takes to read the channel. In cases where accuracy is less
important than speed, you may reduce the resolution.

�����$ ��!����"������
 ��
The channel type varies according to the possible input ranges for the board. It is
also dependent on your selection under Channel Class.

When you select this channel class Channel Type contains this information

Counter No channel types are listed. A special internal
channel type is automatically selected.

Current Allowable ranges.

Digital No channel types are listed. A special internal
channel type is automatically selected.

Thermocouple Allowable thermocouple types:
J: Iron/Constantan
K CHROMEGA-ALOMEGA
T: Copper/Constantan
E: CHROMEGA/Constantan
R: Pt 13% Rh/Pt
S: Pt 10% Rh/Pt
B: Pt 6% Rh/Pt 30% Rh

Volts (for a programmable gain board) Allowable ranges.

Volts (for a non-programmable gain
board)

Hardware settings for the input voltage range on
the board.

�����$ ��!��	���=���
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Cold junction compensation works in conjunction with a thermocouple. A
thermocouple is a temperature measurement sensor that consists of two dissimilar



�"��
���������������������������������������

&)

metals joined together at one end to form a junction. When the junction is heated, a
small thermoelectric voltage is produced.  Cold junction compensation compensates
for the voltage generated on the mux board and subtracts it from the voltage at the
junction. The ��������� block uses the vendor’s specification for the cold junction
compensation. Typically, it is 0. If you physically change the cold junction
compensation on the mux board, use this parameter to make the same change to the
software.

The Cold Junction Compensation parameter is available for use only when the
Thermocouple under Channel Class is activated.
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"���
�6�
���
�8�	�#
You use the ��������	� block to set an output channel on your I/O board.

� To set up an output channel

1. Choose Blocks > Real Time and drag an ��������	� block into the work area.

2. Do one of the following:

• Choose Edit > Block Properties and click the mouse over the ��������	�
block.

• Click the right mouse button over the ��������	� block.

The Real Time Data Output dialog box appears.

3. Make the appropriate selections. (See the descriptions below for more
information about each parameter.)

4. Click on the OK button, or press ENTER.



�"��
���������������������������������������

&5

�����$ ��!�
"��8	�������8��
In the Board Number box, enter the board number of the I/O board whose output
channel is to be configured. The board number was established with the File > Real
Time Config command, as described on page 9. If you are not sure of the board
number, click on the DOWN ARROW to reveal the list of configured board numbers.
When you click on a board number, the board type is displayed beneath the board
number.

�����$ ��!����"������
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You use the Title box to create titles for each output channel. If you are using more
than one output channel on your I/O board, it is a good idea to use channel titles to
distinguish each channel. Channel titles appear on the ��������	� blocks.

�����$ ��!����"���������8��
In the Channel box, you enter a number that correspond to the channel number on
the screw terminal or termination panel supplied with your I/O board.
VisSim/Real-TimePRO and VisSim DACQ use channel 0 as the first channel, even
if the documentation supplied by the board vendor describes the first channel as
channel 1.

8255-based digital I/O boards: If you are using an 8255-based digital I/O board,
you can connect ��������	��channels to electrical connector terminals in several
different ways. Boards with an 8255 chip are listed below:

Vendor Board

Keithley MetraByte PIO-12

PIO-24

ComputerBoards CIO-DIO24

CIO-DIO24H

National Instruments PC-DIO-24

PC-DIO-96

DAQCard-1200

See Appendix A, “Connecting to Boards with an 8255 Chip” for more information.

PCM-CIA DAS 12/16 and DAS 16/16 boards: If you are connecting to a
ComputerBoards PCM-CIA DAS 12/16 or DAS 16/16, you can connect the ���
�����	� channels to electrical terminals in a specific way. See Appendix B,
“Connecting to PCM-CIA DAS 12/16 and DAS 16/16 Boards,” for more
information.
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The ��������	� block recognizes three classes of output channels:

• Analog

• Digital

• Pulse

In general, when you select one of these channel classes, it is assumed that you have
connected the hardware line to the specified channel number.

When you select a channel class, the options listed under the Channel Type box
change accordingly. For example, when you select Volts, the voltage channel types
appear under Channel Type.

�	��
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The Counter parameter outputs high frequency square waves. The counter output
utilizes the board’s counter timer and often re-uses an existing digital I/O channel.
Refer to the documentation accompanying your board for information on wiring this
channel. Data sampling rates of up to 20 KHz (counter-assisted) can be achieved.

As an example of how the counter output operates, consider the control of a stepper
motor/drive system. The drive is capable of receiving command pulses from 0 to 5
kHz to regulate its speed. By connecting a ������ block, with a range of 0 to 5,000,
to the ��������	� block, configured for counter output, the motor speed can be
controlled over its full range.

6�!�
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The Digital parameter provides an ON/OFF channel output. When Digital is
activated, the output behaves like a current sink. When the voltage level on the
digital output line goes low, current flows from the 5 V power supply to ground.
When the digital output channel is activated, the voltage level of the channel goes
low (turns off). Most digital output channels are capable of sinking 10 mA. For
real-time digital output, the inputs generated are Boolean in nature.

The voltages corresponding to the ON/OFF states of the digital channel obey TTL-
level values. Low is less than 0.7 V, and high is greater than 2.5 V.

Digital I/O lines are especially useful for controlling equipment using ON/OFF
signals. Most often, the channel itself will not have enough power to actuate. In
these situations, an opto-isolated solid-state relay is used. These relays, supplied by
the board vendor, are soldered onto the screw terminal panel. Instructions are
provided by the board vendor.

The opto-isolators have a low power side and a high power side. The digital I/O
communicates with the low power side. By connecting a high power source plus
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equipment through the high power side, you can switch high AC or DC power using
the digital I/O line.

Most vendors offer opto-isolator modules ranging from 3 A, with voltages to 280 V
AC, to 45 A, with voltages to 650 V AC.

�	�
���"�����������
The Volts parameter provides a time varying voltage output. The range of the
voltage output is software-selectable for many boards. Boards with this characteristic
are referred to as programmable gain boards. If you are using a programmable gain
board and you activate Volts, the voltage ranges are presented under the Channel
Type box. These typically range from ±10 V to ±0 01. V and lower.

For boards without programmable gain, the output voltage range is normally set
using a micro-switch on the I/O board itself. The corresponding voltage ranges,
listed under the Channel Type box, are read-only settings.

The voltage channel is often called a D/A channel. Analog input signals are
converted to digital representations using a converter. The converter consists of
registers whose numbers determine the resolution. Most boards use 12-bit resolution
converters; however, some boards use higher resolution converters for greater
precision.

Channel resolution is proportional to channel read time. The higher the channel
resolution, the longer it takes to read the channel. In cases where accuracy is less
important than speed, you may reduce the resolution.

�����$ ��!����"������
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The channel type varies according to the possible output ranges for the I/O board.

When you select this channel class The Channel Type contains this information

Counter (for programmable gain or
range board)

There are no channel types listed. A special
internal channel type is automatically selected.

Counter (for non-programmable gain
or range board)

The range value specified with the File > Real
Time Config command.

Digital A special internal type. If the board does not
support programmable ranges or gains, the
channel type is set to the range value specified
with the File > Real Time Config command.
There are no other channel options. There are no
other channel options.

Volts (for a programmable gain board) The allowable ranges from which you can choose.
These are read-only settings.

Volts (for non-programmable gain The hardware settings for the output voltage range
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board) on the board. These are read-only settings.
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This chapter describes how to use the 
�� block to vary a signal’s frequency or
pulse width.

'	���������	�
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The 
�� block is based on the 9513 chip. Any board based on that chip can use the

�� block. Currently, these boards include:

Vendor Board

Analog Devices  RTI 815

ComputerBoards CIO-CTR05

CIO-CTR05/H50

CIO-CTR10

CIO-CTR10/H50

Because VisSim/Real-TimePRO is continually expanding the I/O boards it supports,
it’s a good idea to contact Visual Solutions for the most up-to-date list of supported
boards.
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The 
�� block has two inputs: frequency and % Duty Cycle (or pulse width).

Combined, these two inputs form a signal with the specified frequency and duty
cycle. The duty cycle indicates the percent of time the signal is in an ON state. The

�� block sends the signal to the specified channel on the 9513 counter output.

Although you can dynamically change the input values simultaneously, you typically
vary one or the other input at a time. For example, for power modulation, keep the
frequency fixed at a constant value while varying  the pulse width. Conversely, for
pure frequency output, fix the pulse width and vary the frequency.

�����$ ��!���	���
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Through the Setup dialog box for the 
�� block, you define the base address and
channel number to which the pulse width modulated waveform is sent. You also use
the Setup dialog box to set the clock frequency and to provide the 
�� block with a
unique name.

� To specify PWM block properties

1. Choose Blocks > Real Time and drag a 
�� block into the work area.

2. Do one of the following:

• Choose Edit > Block Properties and click the mouse over the 
�� block.

• Click the right mouse button over the 
�� block.

The 9513 PWM Counter Output Setup dialog box appears.
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3. Do one or more of the following:

Use this parameter To

Name Provide a unique name for your 
�� block. By naming 
��
blocks, you reduce the risk of misreading your diagram,
particularly when you are using more than one 
�� block.

Base Address Indicate the I/O port register address through which the real-
time driver commands the board. Enter the base address as a
hexadecimal number, followed by an optional “H.” If you are
not sure of the board’s base address, use the File > Real Time
Config, as described on page 8, to display this information.

Channel Enter a number that corresponds with the channel number on
the screw terminal or termination panel supplied with your I/O
board. VisSim/Real-TimePRO and VisSim DACQ use channel
0 as the first channel, even if the documentation supplied by the
board vendor describes the first channel as channel 1.

Clock Freq. Enter a value that corresponds with the base frequency crystal
value set on your I/O board. If the value you enter does not
match the base frequency crystal value, erroneous results are
produced.

4. Click on the OK button, or press ENTER.
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This chapter describes how to use the 
���	���� block to measure input frequency
of TTL-level edge transitions, from 0 to 5 V.

'	���������	�
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The 
���	���� block is based on the 9513 chip. Any board based on that chip can
use the 
���	���� block. Currently, these boards include:

Vendor Board

Analog Devices  RTI 815

ComputerBoards CIO-CTR05

CIO-CTR05/H50

CIO-CTR10

CIO-CTR10/H50

Because VisSim/Real-TimePRO is continually expanding the I/O boards it supports,
it’s a good idea to contact Visual Solutions for the most up-to-date list of supported
boards.

����!�
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The 
���	���� block lets you access and read a particular channel on the 9513
counter and use the value of this signal in a VisSim diagram. Functionally, the

���	���� block performs the reverse options of the 
�� block, described earlier
on page 23.
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The 
���	���� block measures a signal on an I/O board at the specified base
address and channel number and outputs the frequency in hertz.

� To specify frequency block properties

1. Choose Blocks > Real Time and drag a 
���	���� block into the work area.

2. Do one of the following:

• Choose Edit > Block Properties and click the mouse over the 
���	����
block.

• Click the right mouse button over the 
���	���� block.

The 9513 Counter Input Setup dialog box appears.

3. Do one or more of the following:

Use this parameter To

Name Provide a unique name for your 
���	���� block. By naming

���	���� blocks, you reduce the risk of misreading your
diagram, particularly when you are using more than one

���	���� block.

Base Address Indicate the I/O port register address through which the real-
time driver commands the board. Enter the base address as a
hexadecimal number, followed by an “H.” If you are not sure of
the board’s base address, use the File > Real Time Config, as
described on page 8, to display this information.
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Use this parameter To

Channel Enter a number that corresponds with the channel number on
the screw terminal or termination panel supplied with your I/O
board. VisSim/Real-TimePRO and VisSim DACQ use channel
0 as the first channel, even if the documentation supplied by the
board vendor describes the first channel as channel 1.

Clock Freq. Enter a value that corresponds with the base frequency crystal
value set on your I/O board. If the value you enter does not
match the base frequency crystal value, erroneous results are
produced.

4. Click on the OK button, or press ENTER.

�����$ ��!����������!���
�
To obtain an accurate measurement, set VisSim’s sampling interval (that is, its
simulation time step) larger than the sample interval of the events you are measuring.
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This chapter describes how to use the ������� block to read quadrature encoded
inputs.
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Currently, only the MFIO-3A board from Precision Micro Dynamics is supported.
However, because VisSim/Real-TimePRO and VisSim DACQ are continually
expanding the I/O boards they support, it is a good idea to contact Visual Solutions
for the most up-to-date list of supported boards.
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Because the MFIO-3A board has quadrature encoder inputs, to access all three
encoder inputs, use three ������� blocks.

�����$ ��!���	���
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� To set up the encoder block

1. Choose Blocks > Real Time and drag a ������� block into the work area.

2. Do one of the following:

• Choose Edit > Block Properties and click the mouse over the �������
block.

• Click the right mouse button over the ������� block.
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The MFIO3a Encoder Setup dialog box appears.

3. Make the appropriate selections. (See the descriptions below for more
information about each parameter.)

4. Click on the OK button, or press ENTER.

�����$ ��!���
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You use the Title box to create a name for the particular encoder channel that is
accessed with the encoder block. By giving unique names to different encoder
inputs, you can easily distinguish between them.

�����$ ��!�
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The base address indicates the I/O port register address through which the real-time
driver commands the board. Enter the base address as a hexadecimal number,
followed by an “H.”

If you are not sure of the board’s base address, use the File > Real Time Config, as
described on page 8, to display this information.

�����$ ��!�
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The Counter Reset Value box lets you reset the value of the index pulse on the
occurrence of the index pulse and according to the counter set mode.

�����$ ��!�
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In the Channel box, you enter a number that corresponds with the channel number
on the screw terminal or termination panel supplied with your MFIO-3A board.
VisSim/Real-TimePRO and VisSim DACQ use channel 0 as the first channel, even
if the documentation supplied by the board vendor describes the first channel as
channel 1.
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Each channel on the MFIO-3A board has an A, B, and Z axis. You can invert one or
more axes to get phasing information.
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The Counter Set Mode lets you reset the counter on your MFIO-3A board to the
value specified in the Counter Reset Value box. You have the following choices:

• You can reset the counter at the start of the simulation.

• You can reset the counter at the first occurrences of the index pulse (which is
also known as the Z trigger).

• You can reset the counter at every occurrence of the index pulse.

You can alternatively not ever reset the counter.
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The two pulse, A and B, are shifted by a quarter of a cycle with respect to each
other. The shift between the two signals enables the controller or the simulation to
determine the direction of rotation, according to whether pulse A leads pulse B, or
vice versa.
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The  Keithley MetraByte PIO-24 board;  ComputerBoards CIO-DIO24 and CIO-
DIO24H boards; and National Instruments PC-DIO-24, PC-DIO-96, and DAQCard-
1200 offer several ways to connect VisSim channels to the electrical connector
terminals. These boards are capable of 24 channels of digital I/O, and can be
configured as all digital inputs, all digital outputs, or byte-wise combinations of
both. The DIO24 can be configured as all input channels; all output channels; or 12
input and 12 output channels.

�	�$�!����������������
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VisSim input
channel

Terminal
connector channel

VisSim input
channel

Terminal
connector channel

0 A0 12 B4
1 A1 13 B5
2 A2 14 B6
3 A3 15 B7
4 A4 16 C0
5 A5 17 C1
6 A6 18 C2
7 A7 19 C3
8 B0 20 C4
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VisSim input
channel

Terminal
connector channel

VisSim input
channel

Terminal
connector channel

9 B1 21 C5
10 B2 22 C6
11 B3 23 C7
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VisSim output
channel

Terminal
connector channel

VisSim output
channel

Terminal
connector channel

0 A0 12 B4
1 A1 13 B5
2 A2 14 B6
3 A3 15 B7
4 A4 16 C0
5 A5 17 C1
6 A6 18 C2
7 A7 19 C3
8 B0 20 C4
9 B1 21 C5
10 B2 22 C6
11 B3 23 C7
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VisSim input
channel

Terminal
connector channel

VisSim output
channel

Terminal
connector channel

0 A0 0 B0
1 A1 1 B1
2 A2 2 B2
3 A3 3 B3
4 A4 4 B4
5 A5 5 B5
6 A6 6 B6
7 A7 7 B7
8 C0 8 C4
9 C1 9 C5
10 C2 10 C6
11 C3 11 C7
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It is important to be aware of how to connect to  ComputerBoards PCM-CIA DAS
16/12 and 16/16 boards. The following table describes how the VisSim channels
map to the terminal connector channels.
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VisSim input
channel

Terminal
connector channel

VisSim input
channel

Terminal
connector channel

0 DIO 0 0 DIO 4
1 DIO 1 1 DIO 5
2 DIO 2 2 DIO 6
3 DIO 3 3 DIO 7
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This appendix covers the following information:

• Installing I/O boards

• Installing and upgrading VisSim/Real-TimePRO

• Installing and upgrading VisSim DACQ
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Installing a new I/O board in your computer is more than just inserting the board into
an empty expansion slot and seating it to the connector. Before you reach this point,
most boards require that you set their base addresses and adjust their jumpers.
Because this information is unique to each board, it is important that you refer to the
vendor’s documentation for installing and testing the board.
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VisSim/Real-TimePRO runs on personal computers using the Intel 80386 or higher
processor, including the IBM Personal System/2 Series, the IBM PC AT, and 100%
compatibles. To use VisSim/Real-TimePRO, your computer must have the following
components:

• Visual Solutions VisSim 3+

• 300K RAM
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• 300K of free hard disk space

• 3½" disk drive

• EGA or higher resolution monitor

You use one of the following installation procedures whether you are installing
VisSim/Real-TimePRO for the first time, upgrading from a previous version, or
stepping up from VisSim/RT. The installation procedure assumes that you are
installing from drive A. If you are installing from a different drive, please substitute
the correct drive designation in the procedure below.

� To install, upgrade, or step up VisSim/Real-TimePRO on Windows 3.1 or
Windows 95

1. Start Windows.

2. Insert the VisSim/Real-TimePRO disk into drive A.

3. Do one of the following:

• Click on Start and choose Run.

• Select File from the Program Manager menu bar and choose the Run
command.

4. In the Command Line box, type A:INSTALL and click on the OK button, or
press ENTER.

 A VisSim/Real-TimePRO dialog box appears.

5. Install asks you where you want to install VisSim/Real-TimePRO. You can
accept the default path (C:\VISSIM30) or type in a different directory. Make
sure that the VisSim/Real-TimePRO files are installed on the same disk and
directory that contain your VISSIM32.EXE.

 If you choose to install VisSim/Real-TimePRO over an earlier version, Install
replaces old VisSim files with new ones. You can control which existing
VisSim files are overwritten as a result of the installation by activating the Ask
Before Overwriting Existing Files check box. An X in the box activates
confirmation.

6. To accept the information in the dialog box, click on the Continue button, or
press ENTER.

 Install displays a dialog box that shows the progress of the installation.

7. When the installation is complete, VisSim displays a dialog box indicating that
VisSim/Real-TimePRO has been successfully installed.

8. Click on the OK button, or press ENTER.
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When you start up VisSim, the ��������� and ��������	� blocks are available
for use.
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VisSim DACQ runs on personal computers using the Intel 80286 or higher
processor, including the IBM Personal System/2 Series, the IBM PC AT, and 100%
compatibles. To use VisSim DACQ, your computer must have the following
components:

• Microsoft Windows 3.1+, 95, or NT

• One MB RAM

• One MB of free hard disk space

• 3½" disk drive

• EGA or higher resolution monitor

You use the following installation procedure whether you are installing VisSim
DACQ for the first time or upgrading from a previous version. The installation
procedure assumes that you are installing from drive A. If you are installing from a
different drive, please substitute the correct drive designation in the procedure
below.

� To install or upgrade VisSim DACQ

1. Start Windows.

2. Insert the VisSim/Real-TimePRO disk into drive A.

3. Do one of the following:

• Click on Start and choose Run.

• Select File from the Program Manager menu bar and choose the Run
command.

4. In the Command Line box, type A:INSTALL and click on the OK button, or
press ENTER.

 A VisSim DACQ dialog box appears.

5. Install asks you where you want to install VisSim DACQ. You can accept the
default path or type in a different directory.

 If you choose to install VisSim DACQ over an earlier version, Install replaces
old VisSim files with new ones. You can control which existing VisSim files are
overwritten as a result of the installation by activating the Ask Before
Overwriting Existing Files check box. An X in the box activates confirmation.
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6. To accept the information in the dialog box, click on the Continue button, or
press ENTER.

 Install displays a dialog box that shows the progress of the installation.

7. Insert the next disk when prompted.

8. When the installation is complete, a dialog box is displayed indicating that
VisSim DACQ has been successfully installed.

9. Click on the OK button, or press ENTER.

VisSim DACQ creates a VisSim group with a VisSim DACQ icon.
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2

Advantech boards, 2
analog input range, 9
analog output range, 9

'

base addresses, 9
determining, 8

board number, 9, 12, 17, 23, 26, 30
board type, 9

�

channel class
counter, 14, 16, 19, 20
current, 15, 16
digital, 15, 16, 19, 20
thermocouple, 15, 16
volts, 15, 16, 20

channel names, 23, 26
channel numbers, 23, 27, 30

input, 13
output, 18

channel settling time, 9
channel titles, 30

input, 13
output, 18

channel type
input, 16
output, 20

channels. See also input channels; output
channels

classes, 14, 18
cold junction compensation, 16
multiplexed subchannels, 13
mux gain, 14
setting input, 11–17
setting output, 17–20

CIO-DIO24H board, connecting to, 33
clock frequency, 23, 27
cold junction compensation, 16
ComputerBoards boards, 2

connecting to electrical terminals on CIO-
DIO24 and CIO-DIO24H, 33

connecting to electrical terminals on
PCM-CIA DAS 12/16 and DAS 16/16,
35

configuring VisSim DACQ, 8–10
configuring VisSim/Real-TimePRO, 8–10
conventions, vii
counter, 14, 16, 19, 20
counter reset value, 30, 31
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counter set modes, 31
current channel class, 15, 16

6

data acquisition
performance degradation, 5
guidelines, 1–5

Data Translation boards, 3
digital channel class, 15, 16, 19, 20

1

encoder block
Base Address, 30
Channel, 30
Counter Reset Value, 30, 31
Coutner Set Mode, 31
direction rotation value, 31
Signal Inversion, 31
supported boards, 29
Title, 30

external mux settling time, 10

.

frequency block
Base Address, 26
Channel, 27
Clock Freq., 27
Name, 26
reading channels, 25
sampling rate, 27
supported boards, 25

>

help
accessing, ix
closing, ix




I/O boards
Advantech, 2
base addresses, 7, 8
ComputerBoards, 2
configuring, 7
Data Translation, 3
installing, 7
Keithley MetraByte, 3
National Instruments, 4
Precision Micro Dynamics, 4
supported, 1

installing VisSim DACQ, 39
installing VisSim/Real-TimePRO, 37

?

Keithley MetraByte boards, 3
connecting to electrical terminals on PIO-

24, 33

,

multiplexed, 13
multiplexed subchannels

mux gain, 14
mux gain, 14
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National Instruments boards, 4

�

PCM-CIA boards
connecting to DAS 12/16, 35
connecting to DAS 16/16, 35

performance degradation, 5
PIO-24 board

connecting to, 33
Precision Micro Dynamics boards, 4
PWM block

% duty cycle input, 22
Base Address, 23
Channel, 23
Clock Freq., 23
frequency input, 22
Name, 23
supported boards, 21

�

Real Time Config (File)
Analog Input Range, 9
Analog Output Range, 9
Base Address, 9
Board Number, 9
Board Type, 9
Channel Settling Time, 9
External Mux Settling Time, 10

real-time drivers, 1
rt-DataIn block, 11–17

Board Number, 12
Channel, 13
Channel Type, 16
CJC, 16
Counter, 14, 16
Current, 15, 16

rt-DataIn block (cont.)
Digital, 15, 16
Multiplex Subchannel, 13
Mux Gain, 14
Thermocouple, 15, 16
Title, 13
Volts, 15, 16

rt-DataOut block, 17–20
Board Number, 17
Channel, 18
Channel Type, 20
Counter, 19, 20
Digital, 19, 20
Title, 18
Volts, 20

�

sampling rates, 27
signal inversion, 31
stepping up to VisSim/Real-TimePRO, 37
subchannels

multiplex boards, 13

�

technical support, ix
thermocouple channel class, 15, 16

�

upgrading VisSim DACQ, 39
upgrading VisSim/Real-TimePRO, 37

�

volts channel class, 15, 16, 20
VxD, 1
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